РАДИОСХЕМЫ



РАДИОФОРУМЫ


СХЕМЫ И СТАТЬИ



  • Страница 1 из 1
  • 1
Архив - только для чтения
Форум радиолюбителей » СХЕМЫ » УСИЛИТЕЛИ » Нет звука на выходе PT2313L (Странное поведение темброблока)
Нет звука на выходе PT2313L
Чт, 04.12.2014, 17:33 | Сообщение # 1        
Витинари
аватар
  Постов: 1503   Друзья 
Кто имел дела с PT2313 или TDA7313, отзовитесь.
Собрал темброблок на PT2313L (полный аналог TDA7313) по этой схеме:
Процессорная часть:

Аудиопроцессор:

Темброблок работает, но очень странно - звук появляется и регулируется только когда дотрагиваюсь пальцем (а еще лучше металлическим предметом) до дорожек платы. Во всех остальных случаях - тишина. На замыкания и неконтакт проверял - все нормально. Что за ерунда? Кондеры пробитые? Или аудиопроцессор дохлый? Но ведь все работает, только через одно место...
Смущает вот что: на схеме в даташите сопротивления резисторов тоже 5.6 кОм, а ниже написано:
Цитата
Note: 1. The Resistor ( R ) Range = 2.0K Ohms to 3.6 K Ohms.
2. Resistor ( R ) Recommended Value = 2.4 K Ohms

Поставил на 2.2 кОм. Не из-за этого ли?
Фото прилагаются.


Файлы: 2462296.gif(47.8 Kb) · 4874003.gif(40.4 Kb) · 3984468.jpg(101.8 Kb) · 1765884.jpg(94.5 Kb) · 2537659.jpg(109.8 Kb)
Чт, 04.12.2014, 20:53 | Сообщение # 2        
N-удалён
аватар
  Постов: 2270   Х 
PT2313 часто попадается брак. За TDA7313 не знаю, в жизни ее не видел. Проверь шину i2c, вообще отсоедини ее и касайся тех участков где проц оживает. Может там по шине вовсе что попало бежит.
Чт, 04.12.2014, 21:24 | Сообщение # 3        
BIOS
аватар
  Постов: 1456   ОК 
Не люблю я эти желтые кондюки, там внутри смд-шка которая любит очень разламыватся и часто отпадают от неё ножки.
Чт, 04.12.2014, 21:37 | Сообщение # 4        
SssaHeKkk
аватар
  Постов: 2291   Друзья 
я ставил 5,6к на предусилитель...все норм рабатает...единственно что на беззвучном режиме все равно еле еле слышна музыка...но это не напрягает
Чт, 04.12.2014, 21:40 | Сообщение # 5        
Витинари
аватар
  Постов: 1503   Друзья 
BIOS, вряд ли бы кондеры там развалились. Все из одной партии, другие работают нормально.
Цитата nickolay78 ()
PT2313 часто попадается брак.

Я про TDA7313 такое читал, что почти стопроцентный брак, поэтому и взял PT. Попробую тогда сначала поменять резисторы, а если не пойдет, поставлю запасную 2313.
Чт, 04.12.2014, 22:22 | Сообщение # 6        
SssaHeKkk
аватар
  Постов: 2291   Друзья 
я думаю резисторы не при чем...
Чт, 04.12.2014, 23:00 | Сообщение # 7        
ГУБЕРНАТОР
аватар
  Постов: 2114   Друзья 
делал на TDA7313, отличная тема, работает классно, резисторов на Ом там нет.
Кондёры нормальные, но вот по входу и выходу ставил бы другие.
Схема преда вот:

я управляю этим:

подозрений 2
1. проверьSDA и SCL
2. подваленая микра
Файлы: 6789163.gif(63.4 Kb) · 7271621.gif(82.1 Kb)
Пт, 05.12.2014, 05:24 | Сообщение # 8        
Витинари
аватар
  Постов: 1503   Друзья 
ГУБЕРНАТОР, о, это же схема МИНИ-16. Вначале тоже склонялся к ней, но за 16-й мегой надо было специально ехать, а пик валялся без дела.
Правильность SDA/SCL проверил сразу - там без ошибок (у автора на схеме они перепутаны).
Все больше склоняюсь к тому, что бракованная микра попалась.
Пт, 05.12.2014, 20:43 | Сообщение # 9        
Витинари
аватар
  Постов: 1503   Друзья 
А дело становится все интереснее. Во-первых, нашел на 1-м входе перепутанные землю и правый канал - исправил. Звук появился. Но...
звук есть, если прикладываю провода от левого и правого каналов (естественно, голос "срезается"), стоит же приложить общий - тишина. Прозвонил всю плату на замыкания - все в норме. Что я опять делаю не так? Может, земля разведена неправильно? В даташитах земля разделена на GND и DGND, у меня - нет.
Файлы: 0140769.gif(45.8 Kb)
Пт, 05.12.2014, 20:51 | Сообщение # 10        
ГУБЕРНАТОР
аватар
  Постов: 2114   Друзья 
разводить земли аналог и цифру обязательно!
Пт, 05.12.2014, 20:55 | Сообщение # 11        
Витинари
аватар
  Постов: 1503   Друзья 
ГУБЕРНАТОР, в оригинале авторская плата выглядит вот так:

Получается, подводить землю с питания надо только к 26 ноге, а все остальное оставить как общий? Типа, так:
Файлы: 5234590.png(96.9 Kb) · 4971757.png(83.6 Kb)
Пт, 05.12.2014, 21:06 | Сообщение # 12        
ГУБЕРНАТОР
аватар
  Постов: 2114   Друзья 
в принципе должно работать и с общими землями, но помехи могут пролезать, думаю не в этом проблема, ищи косяки.
У меня была TDA7313, работала как то через ж-пу, заменил и всё пучком стало.

Добавлено (05.12.2014, 22:06)
---------------------------------------------
вижу, пробуй, но думаю это картину не изменит.

Пт, 05.12.2014, 21:13 | Сообщение # 13        
ГУБЕРНАТОР
аватар
  Постов: 2114   Друзья 
мой вариант под dip:
Файлы: 9003735.lay6(62.5 Kb) · 8671851.jpg(101.5 Kb)
Пт, 05.12.2014, 21:13 | Сообщение # 14        
Витинари
аватар
  Постов: 1503   Друзья 
ГУБЕРНАТОР, если бы они были у нас в дипе, никаких проблем не было бы smile А так только PT2313, и то в смд.
Пт, 05.12.2014, 22:23 | Сообщение # 15        
SssaHeKkk
аватар
  Постов: 2291   Друзья 
вот мой вариант в смд...проверенный
Файлы: _PT2313L.lay6(57.5 Kb)
Сб, 06.12.2014, 12:28 | Сообщение # 16        
Витинари
аватар
  Постов: 1503   Друзья 
SssaHeKkk, спасибо.
Прозвонил тестером обе имеющиеся ПТ, обнаружил вот что: между 3 ногой и входами-выходами стоит что-то типа диода для защиты от переполюсовки, т.к. ноги звонятся только в одну сторону. Те же выводы, которые подключаются к общему (AGND), не должны прозваниваться вообще. При замыкании дорожек AGND и DGND этот диод, конечно, включается везде. Видимо, для TDA7313 это не критично, а вот PT2313 начинает капризничать.

Мистика! Микра явно попалась не то левая, не то дохлая, но какая! biggrin
С раздельным питанием не запускается вообще. Никак. Однако после длительных экспериментов выяснилось, что выходы Right1+Left1 = правый канал, а Right2+Left2 = левый! Жесть какая-то просто! Стоит их соединить - начинаются дикие хрипы. Ну нафиг! Завтра соберу заново, с запасной микрой.
Вс, 07.12.2014, 20:04 | Сообщение # 17        
Витинари
аватар
  Постов: 1503   Друзья 
В общем, начал делать плату заново, заодно добавил конденсаторы по 2.2 uF на выход. Посмотрим, что получится.
Еще нашел полный даташит на PT2313 с описанием всех параметров аудиопроцессора - может, кому тоже пригодится.

Второй заход - результат тот же. Ну эту микру в баню, буду пробовать другие регуляторы.
Файлы: pt2313.pdf(281.6 Kb)
Пт, 12.06.2020, 10:29 | Сообщение # 18        
VOLODIA9041
аватар
  Постов: 2   ОК 
По даташиту на вход или ФМ, или Касета, или радиво. Управляется МЦУ. МЦУ это контроллер? Можно без него обойтись?
Как на выходе 4 динамика, а на входе 2 канала?
Нужно предусилитель лепить после него или сразу на усь подавать?
Пт, 12.06.2020, 21:24 | Сообщение # 19        
ВIOS
аватар
  Постов: 1332   Х 
Цитата VOLODIA9041 ()
МЦУ это контроллер? Можно без него обойтись?

Да, это микроконтроллер, без него не обойтись. Это цифровой аудио процессор.
Цитата VOLODIA9041 ()
Как на выходе 4 динамика, а на входе 2 канала?

Нет. Прочитай первую страницу ДШ и все вопросы отпадут. Там написано 3 стерео входа бла бла бла ....
Форум радиолюбителей » СХЕМЫ » УСИЛИТЕЛИ » Нет звука на выходе PT2313L (Странное поведение темброблока)
  • Страница 1 из 1
  • 1
Поиск:

Внимание! Форум переехал на Tehnodium.ru



© 2010-2022 "Радиосхемы". All Rights Reserved  Почта  PDA